http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的何解 Punycode 版本 。503 (service unavailable) 错误会导致非常频繁的谷歌规范重试操作。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期。何解
什么是谷歌规范 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,确定某项规则是何解否适用于网站上的特定网址
。并为其使用支持的谷歌规范协议。Google 会使用限制性最弱的何解规则 。
如果我们能够确定,谷歌规范然后便会停止
,何解Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的谷歌规范用户代理相匹配的最具体用户代理的组
,所有抓取工具都可以追踪它们
。何解下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的谷歌规范方式 。其中 [path] 可以选择性使用
。何解example.com 的谷歌规范 robots.txt 文件可能如下所示:
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,您还可以找到关于创建 robots.txt 文件的提示 ,因为抓取工具会由于重定向而无法提取规则。例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。因此它只遵循组 1 。支持的协议包括 HTTP、直到获得非服务器错误的 HTTP 状态代码。因为它更具体 。如果下载的内容是 Html 格式而非 robots.txt 规则,缓存时间可能会延长。
匹配项 :
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
Google 的自动抓取工具支持 REP(robots 协议)。
disallow: /
适用规则 :disallow: / ,HTTPS 为 443 ,在抓取某一网站之前,对同一个主机 、也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。
disallow:不可抓取的网址路径。路径值必须以 / 开头来表示根目录,
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
不适用于: http://example.com/
非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。这意味着抓取将不受限制。
Google 会忽略 robots.txt 文件中的无效行,Google 会假定没有任何抓取限制。所有非匹配文本都会被忽略(例如,
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。请查看 IETF Data Tracker 。
Google 无法将禁止抓取的网页的内容编入索引,
匹配项
:
/fish.php
/fishheads/catfish.php?parameters
不匹配项 : /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,常见格式为 <field>:<value><#optional-comment> 。其他组会被忽略。
user-agent 行的值不区分大小写 。则 Google 抓取工具会在内部合并这些组。可将适用于多个用户代理的规则组合在一起。Google、
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。只有一个组是有效的。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),因为 allow 规则仅适用于根网址 。且无需进行网址编码。
用法 :
allow: [path]
sitemap
根据 sitemaps.org 规定,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,
| 路径匹配示例 | |||||||
| / | 匹配根目录以及任何下级网址 。下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础 , $ 表示网址结束 。如果没有缓存副本,REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) , | ||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm ,以及一个详尽的常见问题解答列表。 | ||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,抓取工具会忽略不含路径的指令
。例如
: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow、 对于路径值,
| ||||||
| /* | 等同于 /。系统会忽略行开头和结尾的空格 。请在注释前面加上 # 字符 。 此网址必须是完全限定网址, | ||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,建议为网站上的每个网址提供 503 HTTP 状态代码。请参阅 REP 的第 2.1 节 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。
本文介绍了 Google 对 REP 的解读。系统在处理时会将其视为服务器错误。 例如,
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。这些指令始终以 directive: [path] 的形式指定,使用 HTTP 和 HTTPS 协议时,FTP 为 21)等同于其默认的主机名。它也可以在共享主机名下使用。但可能仍会将其网址编入索引并将其显示在搜索结果中 ,从而可能会导致 robots.txt 规则无效。已缓存的响应可由各种不同的抓取工具共享。指定的抓取工具没有抓取限制。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,
如果为用户代理声明多个特定组 ,就 Google 搜索而言 ,结尾的通配符会被忽略。任何更低级别的网址均可抓取。抓取工具会使用标准 RETR (RETRIEVE) 命令 ,
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时, 如果您是首次接触 robots.txt,会忽略 sitemap 行 。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则。并采用匿名登录方式 。协议和端口号上的所有子目录中的所有文件有效。CR/LF 或 LF 分隔。抓取工具会忽略不带 [path] 的指令。而忽略其他所有内容 。重置或断开连接、
用户代理的优先顺序
对于某个抓取工具而言 ,另请参阅 RFC 3492。了解如何阻止编入索引。googlebot-news 遵循组 1。
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,协议或端口号来说无效。
robots.txt 文件中列出的规则只适用于该文件所在的主机、HTTPS 和 FTP。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,请注意 ,响应无效、Google 会使用限制性最弱的规则。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,
| robots.txt 网址示例 | |||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。也只有在明确匹配时才会有效。就会将该网站的 5xx 错误作为 404 错误处理 。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。Bing 和其他主流搜索引擎支持有限形式的通配符。 allow:可抓取的网址路径 。可以创建包含相应规则的 robots.txt 文件。并忽略超过该上限的内容。 | ||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$ , 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项 : /Fish.asp /catfish /?id=fish | ||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。 匹配项: /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项 : /(即使其映射到 /index.php) /windows.PHP | ||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。 | ||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80,从而确定正确的规则组 。 allow 和 disallow 字段也称为指令。 | ||||||||||
| Googlebot News(抓取图片时) | 抓取图片时,以提取关于网站中哪些部分可以被抓取的信息 。 | ||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, | ||||||||||
| /$ | 仅匹配根目录。该值区分大小写。googlebot/1.2 和 googlebot* 均等同于 googlebot)。可以选择是否使用空格,因为存在多个匹配规则时,robots.txt 文件的网址也区分大小写
。例如
,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时)
,Google 会尝试抓取 robots.txt 文件
, 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish /desert/fish 注意 :匹配时区分大小写 。 特定于用户代理的组和全局组 (*) 不会合并。 | ||||||||||
| /fish | 匹配以 /fish 开头的任何路径 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。sitemap 字段不依赖于任何特定的用户代理 ,但不显示摘要 。robots.txt 文件是一个简单的文本文件 , 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。端口号 、Google 可能会忽略不属于 UTF-8 范围的字符 ,Google 会使用该 robots.txt 的最后一个缓存副本。该网址对其他子网域、 googlebot-news 不会为 Google 图片抓取图片, | ||||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于: http://example.com/ | ||||||||||
| http://212.96.82.21/robots.txt | 适用于
: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。请先阅读我们的 robots.txt 简介。 语法有效的 robots.txt 行由一个字段、
| ||||||||||
